playSMS Forum

[solved] SMS Server Tools 3 not doing anything

I have followed this tutorial to install PlaySMS with SMS Server Tools 3:

Now maybe I don’t know how to use the PlaySMS interface but I couldn’t manage to make the interface working. So SMS Server Tools 3 is working, I see the incoming messages in /var/spool/sms/incoming and if I send a message using sendsms 407xxxxxx ‘text’ I see the message being created in /var/spool/sms/modem1 and then I receive it on my phone. However when I try to use PlaySMS to send messages nothing happens, no error, no message being created in /var/spool/sms/outgoing or /modem1. Also I cannot see the incoming messages in the inbox.

This is my /etc/smsd.conf:

Global configuration

devices = GSM1

loglevel = 4

eventhandler

eventhandler = /usr/local/bin/heating

logfiles

stats = /var/log/sms/stats
logfile = /var/log/sms/smsd.log

Default queue directory = /var/spool/sms

outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent

do not set report folder, let status report files saved in incoming

#report = /var/spool/sms/report

delaytime = 2
errorsleeptime = 10
blocktime = 180
autosplit = 3
#receive_before_send = yes

Queue configurations

[queues]
GSM1 = /var/spool/sms/modem1

Modem configurations

Modem name: GSM1

Modem type: Huawei E367 USB

[GSM1]
#init = AT+CNMI=2,2,0,1,0;+CMEE=1
init = AT^CURC=0
memory_start = 0
device = /dev/ttyUSB2
baudrate = 19200
incoming = yes
report = yes
queues = GSM1

This is my outgoing routing configuration:

Also I have configured Gateway SMS Server Tools 3:
Gateway name: smstools
Default default_queue directory: /var/spool/sms/outgoing

And added a new smsc with:
Gateway: smstools
SMSC name: smstools
Receiver number:
Queue directory:

Then I go to My Account -> Compose Message, I add my phone number 40754xxxx, select Good morning template and hit send. And then I get:
Your message has been delivered to queue (queued:1 failed:0)

I go to Reports -> View SMS Queue:
a7f12ee583a3783b581f38456a62f3ac admin 2020-05-18 17:30:31 1 Hi u there, good morning!!

The message is in there, but it never gets send. Also my log file says:

2020-05-18 17:30:31 PID5ec29c0782413 admin L2 sendsms # start uid:1 sender_id:[playSMS] smsc:[]
2020-05-18 17:30:31 PID5ec29c0782413 admin L2 sendsms_queue_create # saving queue_code:a7f12ee583a3783b581f38456a62f3ac src:playSMS scheduled:2020-05-18 17:30:31
2020-05-18 17:30:31 PID5ec29c0782413 admin L2 sendsms_queue_create # saved queue_code:a7f12ee583a3783b581f38456a62f3ac id:6
2020-05-18 17:30:31 PID5ec29c0782413 admin L2 sendsms # dst_count:1 sms_count:1 total_charges:0
2020-05-18 17:30:31 PID5ec29c0782413 admin L2 sendsms_queue_push # saving queue_code:a7f12ee583a3783b581f38456a62f3ac dst:40754476519
2020-05-18 17:30:31 PID5ec29c0782413 admin L2 sendsms_queue_push # saved queue_code:a7f12ee583a3783b581f38456a62f3ac smslog_id:6
2020-05-18 17:30:31 PID5ec29c0782413 admin L2 sendsms # end queue_code:a7f12ee583a3783b581f38456a62f3ac queue_count:1 sms_count:1 failed_queue:0 failed_sms:0

Any idea as to what I am doing wrong?

Hi,

First of all, please use this installation guide:

Or if your playSMS will open to the internet (using public IP), you must use HTTPS, see this:

You must not use old version of playSMS as they are all have critical security vulnerability.

You can still follow smstools3 manual from this URL (near end of article, Install smstools):


Now, since your smstools3 is working so we can just debug the playSMS side. First, edit config.php and change logstate to 3 to get more info of what happen when you send test SMS or receiving it.

Looking at the pieace of log you pasted looks like no playsmsd running. Following the installation article above will get you to setup playSMS properly, including making sure playsms daemon is running.

anton

Indeed followed the above tutorial(the Install PlaySMS part and below) and reinstalled the PlaySMS and now it works. I can see the incoming messages and I can send messages.As a side note, the incoming messages are in Sandbox, not in All Inbox, but that is not an issue.

Thanks for the quick reply Anton!