playSMS Forum

Short code with + sign is removed when sending


(Andres Maduro) #1

Hi Anton,

I am connecting to an SMSC through Kannel plugin and found that the operator is requiring the + sign in both the sender and receiver. No problem for the originating number as config allows to remove/add + or leave as is, but… the destinationnumber, in my case a short code or sender_id has the + sign removed when I see the access.log in kannel.

When sending from Compose Message for example from +18xxxxxxxxx to +7625, the + is removed from 7625 as you can see on the access.log from Kannel below.

How can I fix this ? I am certainly going deep into the code but want to give a solution tht won’t break other Kannel connections or modules.

Any advice is very welcome!

2018-12-11 20:56:00 FAILED Send SMS [SMSC:smsc-operator] [SVC:smsc-operator] [ACT:andres] [BINF:] [FID:] [META:?smpp_resp?] [fr
om:7625] [to:+18XX9992601] [flags:-1:0:-1:-1:27] [msg:37:Miguelito, a ver si te llega prueba 6] [udh:0:]
2018-12-11 20:56:00 Receive DLR [SMSC:smsc-operator] [SVC:smsc-operator] [ACT:] [BINF:] [FID:] [META:?smpp_resp?] [from:7625] [
to:+18XX3XXX601] [flags:-1:-1:-1:-1:16] [msg:38:NACK/0x0000000a/Invalid Source Address] [udh:0:]

Best regards.

Thanks for this great system!


(Edilson Spessoto) #2

Could you configure the from directly into kannel sendsms-user, faked-sender, maybe?


(Edilson Spessoto) #3

Or then, try to see into playSMS logs on which point the plus sign is removed


(Andres Maduro) #4

Hi, thanks for the suggestion! This has been solved!

It seems it was a mistake with “Module Sender ID” in Kannel config. I set it up as the sender id and that breaks Kannel sending. Clearing this parameter and leaving it empty solved the issue.

The operator allows to send without + sign but all received messages come with + prefixed on both numbers.

Best regards.