Unable to send SMS using Huawei e3131


(Will Curtis) #1

Hi Guys,

Im not sure the issue is related directly to the Huawei e3131 but I have ran out of ideas! Messages sent from the web portal seem to go in to the queue but just sit at pending and nothing is received by the destination phone. My setup is as follows

Raspberry Pi 3 (latest version) Latest distribution and all packages up to date
Huawei e3131 USB Modem (unlocked)
GiffGaff SIM
Latest version of PlaySMS and SMSTools 3

You can see that messages are being queued:

2016-10-15 20:10:07 PID58027f0e56215 admin L2 sendsms # start uid:1 sender_id:[07522551996] smsc:[]
2016-10-15 20:10:07 PID58027f0e56215 admin L2 sendsms_queue_create # saving queue_code:97072a92bcc25bce2cbfb367cc100af6 src:07522551996 scheduled:2016-10-15 20:10:07
2016-10-15 20:10:07 PID58027f0e56215 admin L2 sendsms_queue_create # saved queue_code:97072a92bcc25bce2cbfb367cc100af6 id:9
2016-10-15 20:10:07 PID58027f0e56215 admin L2 sendsms # dst_count:1 sms_count:1 total_charges:0
2016-10-15 20:10:07 PID58027f0e56215 admin L2 sendsms_queue_push # saving queue_code:97072a92bcc25bce2cbfb367cc100af6 dst:447921525054
2016-10-15 20:10:07 PID58027f0e56215 admin L2 sendsms_queue_push # saved queue_code:97072a92bcc25bce2cbfb367cc100af6 smslog_id:9
2016-10-15 20:10:07 PID58027f0e56215 admin L2 sendsms # end queue_code:97072a92bcc25bce2cbfb367cc100af6 queue_count:1 sms_count:1 failed_queue:0 failed_sms:0

Any Ideas?

UPDATE: I now have this working, turns out it was the baud rate on the modem configuration! I noticed that everything runs as root, is that normal? even the web directories are owned by root instead of www-data?


(Ricardo Camacho) #2

It would be useful if you detailed your baudrate findings so people like me who have a similar issue with pending messages know what to look for or change? :wink: