playSMS Forum

[solved] Twilio not working while other gateways work

Hi
Brand new installation for the first time ever - no SMS experience before
I ma trying outgoing for now and it works perfect with Nexmo but nothing happens when I Try my Twilio - The log is set to 3 and even the log for both gateways is the same and I don’t see any error
I checked the config.php for Twilio and the api url is https://api.twilio.com but I believe it has to be https://api.twilio.com/2010-04-01 - charged it but still not working

Any suggestion ? When i check my Twilio console nothing hits it/

Twilio requires senderid (as acquired from them) set in order it can send messages.

Thanks for the reply
I am using my “E.164 formatted Twilio Phone number” as senderid , is that correct ? cause it is not working - If not , where can I find my Senderid in my Twilio portal ?

It does have bugs, with the callback url set by plugin. I’ve fixed it and tested it. It will be pushed to github soon.

anton

made a mistake here, upon more testing I found that the plugin is working properly as is

Tried again not working , and nothing shows up in Twilio’s Dashboard
Any suggestions ? PlaySMS Log shows no error at all
Nexmo works fine
Receive from Twilio works too

Here is my setup:

In Settings -> Manage gateway and SMSC, do menu 1 and then 2 (pointed by arrows below):

In Manage twilio, the step 1 pointed by arrow above, put correct Account SID, Auth Token and Module sender ID (Module sender ID is the phone number you set in Twilio dashboard):

After that back to Manage gateway and SMSC and add SMSC for Twilio, the step 2 pointed by arrow above. There you just give a name to twilio SMSC, in my example its twilio1:

By adding SMSC you can then route outgoing SMS to it, routing done in Settings -> Route outgoing SMS:

  • In my example above I setup route for every SMS prefixed with 628 to SMSC twilio1. Country code is 62, but I know 628 is mobile prefix so thats why Im using it instead just 62 the country code.

And last, since Twilio requires the from and to to have a plus sign then I just set it in Settings -> Main configuration, and also I empty the Default sender ID (read about the sender ID priority somewhere in the Forum):

  • Default prefix or country code set to 62, it means when user send to 089012345 it will be modified playSMS to 6289012345 (replace 0 with country code)
  • Always remove plus sign set to yes, I expect my users dont send SMS with + sign
  • Always add plus sign set to yes, but then since Twilio requires plus sign for country code then I set so that playSMS will add it automatically when sending to SMSC (in my case to twilio1)

You can examine playsmsd.log to know whats going on. Here is an example of successful sent, but with failed sent also about the same, the error message from Twilio is in the red marker below:

Started from scratch and followed up your instructions and it “WORKED”
Thank you so much -
Not sure what I was doing wrong

@anton I have a provider which is not in the list - I need to write the plugin - I do not code
Is that something you do ? or know anyone who does ?
Willing to pay for it
Thanks

Which provider do you want to connect to? Which integration methods does it provides? SMPP, HTTP?

ISPTelecom is a CLEC provider in Canada
HTTP

Have you tried to create a smsc using Generic HTTP gateway? If doesn´t work, will have to develop a specific gateway plugin to such carrier