playSMS Forum

[solved] SMS Won't Send as Email "sendmail # end with error:it was not possible to read line from socket"

Hi,

I’m trying to set up playSMS to send text messages by email, but instead, I receive the error “sendmail # end with error:it was not possible to read line from socket” when the system tries to send a text message as an email.

192.168.168.146 192.168.168.110 2015-09-10 16:25:53 PID55f1e751c1087 admin L3 recvsms # isrecvsmsd:1 dt:2015-09-10 16:25:49 sender:1111111111 m:Hi receiver:1234 smsc:dev
192.168.168.146 192.168.168.110 2015-09-10 16:25:53 PID55f1e751c1087 admin L3 dev__incoming # Array ( [0] => Sender ID: 1111111111 [1] => Receiver number: 1234 [2] => Sent: 2015-09-10 16:25:49 [3] => Message: Hi )

    • 2015-09-10 16:25:54 PID55f1c1fa8f0e1 - L3 recvsmsd # id:1088 dt:2015-09-10 16:25:49 sender:1111111111 m:Hi receiver:1234 smsc:dev
    • 2015-09-10 16:25:54 PID55f1c1fa8f0e1 - L3 recvsms_process # dt:2015-09-10 16:25:49 sender:1111111111 m:Hi receiver:1234 smsc:dev
    • 2015-09-10 16:25:54 PID55f1c1fa8f0e1 - L3 recvsms_process # unhandled datetime:2015-09-10 16:25:49 sender:1111111111 receiver:1234 message:Hi
    • 2015-09-10 16:25:54 PID55f1c1fa8f0e1 - L3 incoming__recvsms_intercept_after # sandbox to user start u:admin dt:2015-09-10 16:25:49 s:1111111111 r:1234 m:[Hi]
    • 2015-09-10 16:25:54 PID55f1c1fa8f0e1 - L2 recvsms_inbox_add # saving sender:1111111111 receiver:1234 target:admin reference_id:
    • 2015-09-10 16:25:54 PID55f1c1fa8f0e1 - L2 recvsms_inbox_add # saved id:1056 sender:1111111111 receiver:1234 target:admin
    • 2015-09-10 16:25:54 PID55f1c1fa8f0e1 - L3 recvsms_inbox_add # send email from:T***@gmail.com to:G***@***.com message:[Hi]
    • 2015-09-10 16:25:54 PID55f1c1fa8f0e1 - L2 sendmail # start from:T***@gmail.com to:G***@***.com subject:Message from 1111111111
    • 2015-09-10 16:26:04 PID55f1c1fa8f0e1 - L2 sendmail # end with error:it was not possible to read line from socket
    • 2015-09-10 16:26:04 PID55f1c1fa8f0e1 - L3 recvsms_inbox_add # sent email from:T***@gmail.com to:G***@***.com
    • 2015-09-10 16:26:04 PID55f1c1fa8f0e1 - L3 incoming__recvsms_intercept_after # sandbox to user end u:admin

Any idea on what the problem might be? I’d appreciate any input. Thanks!!

Were you configure smtp access on config.php ?

Anton

Yes, I believe I configured smtp access on config.php. I would share exactly what I put, but I’m not currently located where I have access to check until tomorrow morning, about 12 hours from now.

It should be something like…

$core_config[‘smtp’][‘relm’] = ‘gmail.com’; // yes, not realm, its relm
$core_config[‘smtp’][‘user’] = ‘T***@gmail.com’;
$core_config[‘smtp’][‘pass’] = ‘P***’;
$core_config[‘smtp’][‘host’] = ‘smtp.gmail.com’;
$core_config[‘smtp’][‘port’] = ‘993’;

Is that what you mean? If so, is that correct?

Thank you so much for what you do!!

Hi,

I never tried to use gmail SMTP directly, I believe it won’t work properly.

I recommend you to install postfix and leave config.php as is, then you configure postfix to relay to gmail.

anton

OK, awesome! I will try that tomorrow and respond to say if I had any success. I appreciate the help!!!

Hello,

Your gmail settings are wrong.
gmail smtp holds on ports 465 or 587, not 993

Oh wow, you are right that I used an incorrect port! Thank you for pointing that out!! I can’t believe I made that mistake…

Although, for certain reasons, I’m going to end up using SendGrid, so my problem is solved overall.

Thank you,
Greg

Hi ggnome7 did you get it working? i can´t get it work, same socket error with sendgrid service.

the config.php

The data in config.php:

$core_config[‘smtp’][‘relm’] = ‘sendgrid.net’; // yes, not realm, it’s relm
$core_config[‘smtp’][‘user’] = ‘mysendgridusername’; <- i have tried the email account too. X-(
$core_config[‘smtp’][‘pass’] = ‘mysendgridpass’;
$core_config[‘smtp’][‘host’] = ‘smtp.sendgrid.net’;
$core_config[‘smtp’][‘port’] = ‘465’; <–i have tried all ports (25, 587 and 465)

Did you do something different?

Thank you.

Hello jjhunter,

Yes, I was able to make it work.

  1. To start, please try leaving relm blank as in…

    $core_config[‘smtp’][‘relm’] = ’ '; // yes, not realm, it’s relm

  2. Please use your entire email address for user.

  3. Also, I used port 587

With your changes, I believe you also need to be sure to restart playsms.

Please let me know if that works.

1 Like

Thank you worked like a charm for my setup!