playSMS Forum

[solved] Problem with umlauts(ü,ä,ö) in incoming SMS

I have installed playSMS with SMS Server Tools 3 and a CT63 Modem on a Ubuntu Server.

My Problem is, when I get a incoming SMS with umlauts(ü,ä,ö,…) only the Part until the first umlaut is shown in the Web-interface. In the Database is also only this Part saved. When I turn off the playsms-Daemon and look at the file which the SMS Server Tool created, the whole message is saved in the file (but the umlauts also cannot be read because the are encoded).

Example:
When I send a SMS with the Message “Test ü ä ö” to the SMS Server only “Test” is shown in the Web-Interface

I would be very grateful, if someone could help me.

Please share your SMS Server Tools 3 config file.

Which playSMS version r u using ?

anton

I am using playSMS Version 1.3.1

Here my SMS Server Tool 3 config file:

# Global configuration
devices = cepct63

loglevel = 5

# logfiles
stats = /var/log/sms/stats
logfile = /var/log/sms/smsd.log

outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent

delaytime = 2
errorsleeptime = 10
blocktime = 180
autosplit = 3

# Queue configurations
[queues]
modem1 = /var/spool/sms/modem1

[cepct63]
device = /dev/ttyACM0
baudrate = 115200
incoming = yes
keep_open = yes
cs_convert = yes
report = no
rtscts = no
report_device_details = yes
queues = modem1
pin = 4615

regular_run_interval = 60
regular_run_cmd = AT+CREG?;+CSQ;+COPS?
regular_run_statfile = /dev/shm/sms_stat

Try this setting:
incoming_utf8 = yes
See more here:
http://smstools3.kekekasvi.com/index.php?p=configure

2 Likes

Thank you very much!!

Now it is working

You are welcome, it fixed problem with Danish æøå letters for my setup.
So I thought it would be same problem for you. :wink:

hello ressel, i got the problem with sending but via playsms with gateway gammu. when i use cmd in windows everything works fine, but via playsms i get characters which are not german symbols example ö ä ü doesn’t work