[solved] I have installed playsms fresh and i am Fail to add credit


(Web Voice) #1

i have installed playsms 1.4 in ubuntu server 16.0.4
in virtual box
all the things where fine but i can’t add credit


(Anton Raharja) #2

Can you explain more about that, what did you do, what menu, what error you saw etc…

Anton


(Web Voice) #3

i can’t add credit to admin in manage credit option in setings.


(Anton Raharja) #4

is your playSMS an upgrade or fresh install ?

anton


(Web Voice) #5

fresh
on Ubuntu server 16 running in virtual box on windows 7.


(Web Voice) #6

can i manully add credit to admin using phpmyadmin? i am new to playsms . please help me?


(Anton Raharja) #7

ok, that is odd as I also installed fresh and not getting that error

can you paste the log ? search how to set loglevel to 3 on config.php before saving the log

anton


(Web Voice) #8

thanks for your reply. I created a new server and installed playsms on it. that fixed my problem. thank you so much for outstanding software.


(Pp) #9

Hello Guys , Same issue here how ,How can i solve this issue , i tried fresh install no luck


(Geeth) #10

Hello friends,

I’m also same i just tried with 1.4 with cent OS7.2, credit can’t added


(Neo) #11

The same, can’t add credit to admin and other users. Fresh install of Ubuntu 16.04, php7, gammu, playsms1.4. Please help.


(Jessel Malonzo) #12

Hi Web Voice,

What did you do fix the issue?

Thank you.


(Jose Finoso) #13

anton thanks for answering the OP’s question as i had the same issues and i was searching for answers. i’m currently sitting home doing nothing but searching for rx coupons because of my health issues and lack of money. but in the meantime i decided to learn a bit so thanks everyone else for answering. I haven’t tried your method but I will, would you mind if i’m going to have other questions in case it doesn’t work?


(Adham Al Awadhi) #14

I have the same issue, and i got this message from log:

10.0.2.2 127.0.0.1:800 2017-10-05 19:43:42 PID59d6613e291fe admin L3 credit_add # fail to save parent_uid: uid:2 username:adham amount:10


(Edilson Spessoto) #15

It looks like some database inconsistency. I anyone can give me access to your playSMS install, I can test, debug and, possibly solve.


(Mookz) #16

It is a issue with the version of MySQL that installs on Ubuntu 16.04
I had to change one of the tables from INT to VARCHAR this allows to add credit but then it breaks something else along the line.
Quoting from a post I found online: “parent_uid colum by changing the type (from int to string or varchar) and to accept empty string (NULL checkbox checked) or using 0 as default value”

Before doing that you could try:
Try modifying mysqld.cnf (I would suggest making a backup of the file first)
nano -w /etc/mysql/mysql.conf.d/mysqld.cnf

and add below to the end of the file:
sql_mode=NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION


(Anton Raharja) #17

Hi,

This issue has been fixed in recent commit

anton