OpenVox GSM GW and routing outgoing SMS

(Sergei Romanovskii) #1

I have problem with OpenVox 44SIM GSM GW

In GW manual http to SMS there are this string sample username=admin&password=admin&phonenumber=1363291902 6&message=test&port=gsm-4.2&report=String&timeout=

In my case I need routing for outgoing SMS via specified OpenVox GW (0…5) and specified SIM port (gsm-1.4 … gsm-11.4)

How I can add port parameter to GW settings in Manage gateway and SMSC section?

And how I can rout outgoing SMS via specified gw and specified port.

I try routing by prefix (01-05) PlaySMS select necessary SMSC but OpenVox receive number with prefix like 0179XXXXXXX … and SMS not sending (

Modifying PlaySMS OpenVox plugin to accomodate GSM port settings
(Adesh Johnson) #2

To use a different GW, just add a new SMSc for it.

To use a different port, you will need to make some small modifications/additions in the source code of the plugin (PATH_OF_PLAYSMS/plugin/gateway/openvox) to add the new field for GSM Port. I needed and made it, it’s so easy.

(Edrico Duero) #3

@adeshjohnson please share the code you made for the additional field and what file?

Thank you.

(Paolo Miguel Bartolo) #4

Hello! Are there any updates for this? I’m currently a beginner when it comes to modifying plugins (and I’m sure I’m not the only one) so it would be very helpful if someone posts the code they made for the additional fields. Thanks! :slight_smile: