playSMS Forum

[howto] playSMS 1.4.3 installation on CentOS 7

I wrote howto install playSMS 1.4.3 on CentOS 7, here:

If you have questions related to the article, please post here and let’s discuss it.

anton

Where I can find the trouble?

I don’t know what to do anymore!

Curiosity: Why Komodo? Why a new user and new folders? I’ve followed all the steps. Bu remember: I’ve already have a full lamp system (ASTERISK&FREEPBX). All dependencies of php are in the list.

PHP 5.6.40 (cli) (built: Jan 22 2019 23:51:52)
Copyright © 1997-2016 The PHP Group

playsmsd check
PLAYSMSD_CONF = /etc/playsmsd.conf
PLAYSMS_PATH = /var/www/html/playsms
PLAYSMS_LIB = /usr/lib/playsms
PLAYSMS_BIN = /usr/bin/playsms
PLAYSMS_LOG = /var/log/playsms
DAEMON_SLEEP = 1
ERROR_REPORTING = E_ALL ^ (E_NOTICE | E_WARNING)
IS_RUNNING =
PIDS schedule =
PIDS ratesmsd =
PIDS dlrssmsd =
PIDS recvsmsd =
PIDS sendsmsd =

MariaDB [(none)]> select host, user, password from mysql.user;
±----------------------±------------±------------------------------------------+
| host | user | password |
±----------------------±------------±------------------------------------------+
| localhost | root | |
| localhost.localdomain | root | |
| 127.0.0.1 | root | |
| ::1 | root | |
| localhost | | |
| localhost.localdomain | | |
| localhost | freepbxuser | xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx |
| localhost | playsms | xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx |
±----------------------±------------±------------------------------------------+
8 rows in set (0.00 sec)

komodo is just an example, you can use your own username, but keep up with the article (change all komodo into your own username).

You have to use a normal user, not root, because its dangerous (https://github.com/TheeBlind/CVE-2018-18387).

Ok. So, lets start by checking your installation. Can you browse playSMS ? Can you login to your playSMS from web ?

Update: Let’s continue on the original post, ERROR: Installing PlaySMS on Sangoma7 (centos+Freepbx+Asterisk))

anton

Rui, maybe I can take a loot into your server. Please, drop me a message.

Hi Anton is there a guideline for upgrading from 1.4.2 to 1.4.3 ?

Hmm no not yet. You can replace all files with 1.4.3 files, web files only and playsmsd/playsmsd.php. You can skip DB upgrade.

anton