German Umlaute (äüö) are not sent

(Manfred Stanossek) #1

Hello from Austria,
thx for this great tool.

Using Playsms 1.4.1 on Raspian with smstools 3.1.15

When i use mail2sms feature, german umlauts are transformed to question marks


Test SMS äöuß

get it on my mobile as
Test SMS ???

Mails from the web frontend are correct.

Kind regards

(Scott) #2

I think that you have to enable UTF8 characters in SMSTOOLS.

(Manfred Stanossek) #3

Hello Scott.

Of course i checked the smstools3 homepage, but in Raspian Repository there is only Version 3.1.15 available. UTF-8 Support is introduced with 3.1.16 ;-\

But SMS sent via the WEB GUI are still fine (including Gerrman Umlaute)

Kind Regards

(Manfred Stanossek) #4

Also tried gammu as smsc, same problem

I think it is a problem in fn.php of the mailsms feature.
Kind regards

(mateus domingos) #5


Check if gammu_smsdrc file OutboxFormat option is configured as unicode. If so, change to auto.

Then try send massage from gammu or playsms using gammu as smsc

(Manfred Stanossek) #6

The Problem ist not in the smsc, it seems to be in the mailsms feature