playSMS Forum

Error in error.log

In /var/log/playsms/error.log I have this error lines:

2020/04/14 20:02:40 [error] 562#562: *149 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Error: Call to undefined function user_session_get() in /var/www/playsms/plugin/core/auth/fn.php:168
Stack trace:
#0 /var/www/playsms/init.php(286): auth_isvalid()
#1 /var/www/playsms/index.php(19): include('/var/www/playsm...')
#2 {main}
  thrown in /var/www/playsms/plugin/core/auth/fn.php on line 168" while reading response header from upstream, client: 192.168.10.22, server: 192.168.10.23, request: "GET /index.php?app=ws&op=credit HTTP/1.0", upstream: "fastcgi://127.0.0.1:9000", host: "example.com
", referrer: "https://example.com/"
2020/04/14 20:02:51 [error] 562#562: *151 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Error: Call to undefined function user_session_get() in /var/www/playsms/plugin/core/auth/fn.php:168
Stack trace:
#0 /var/www/playsms/init.php(286): auth_isvalid()
#1 /var/www/playsms/index.php(19): include('/var/www/playsm...')
#2 {main}
  thrown in /var/www/playsms/plugin/core/auth/fn.php on line 168" while reading response header from upstream, client: 192.168.10.22, server: 192.168.10.23, request: "GET /index.php?app=ws&op=credit HTTP/1.0", upstream: "fastcgi://127.0.0.1:9000", host: "example.com
", referrer: "https://example.com/"
2020/04/14 20:03:00 [error] 562#562: *154 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Error: Call to undefined function user_session_get() in /var/www/playsms/plugin/core/auth/fn.php:168
Stack trace:
#0 /var/www/playsms/init.php(286): auth_isvalid()
#1 /var/www/playsms/index.php(19): include('/var/www/playsm...')
#2 {main}
  thrown in /var/www/playsms/plugin/core/auth/fn.php on line 168" while reading response header from upstream, client: 192.168.10.22, server: 192.168.10.23, request: "GET /index.php?app=ws&op=credit HTTP/1.0", upstream: "fastcgi://127.0.0.1:9000", host: "example.com
", referrer: "https://example.com/"

Respectfully,
Jamshid Tursunov

Hi, which playSMS version ? Is that a new install ? Is that new error ?

anton

Good day!

which playSMS version ? 1.4.3
Is that a new install? No
Is that new error ? Yes

Respectfully,
Jamshid Tursunov

So the error is always there after upgrade to 1.4.3 ? Does it affect the service ? I mean does it make playSMS not working ?

If new, what was causing it, because my install dont have that

anton

So the error is always there after upgrade to 1.4.3 ? No, I recently discovered a problem, after the update there was no such error

Does it affect the service ? In the service, so far, has not revealed any deviations

I mean does it make playSMS not working ? No, the service is working, no problems have been identified

If new, what was causing it, because my install dont have that: I don’t know what exactly causes the problem, but the problem is related to authentication.

Respectfully,
Jamshid Tursunov

if Im not mistaken you’re using PHP 7.4 is it ?

anton

Yes Anton, that’s right.

Respectfully,
Jamshid Tursunov