Documentation of FreeBSD install and language bug


(MOREL Geoffrey) #1

Hi Everybody,

Sorry in advance for my bad english,
As a first step, I want to thank for the realization of this project and the topics. The work is exeptional, the follow-up is perfect. Thank you for your time.

I want in a second time give you my documentation of a playsms installation on FreeBSD OS (11.0-RELEASE-p1)
Actually, I have a problem, detailled after topics.

I used FreeBSD and Nginx because I’m used to it.
FreeBSD is focused compilation.
So I used only the package manager to install small bricks (wget, bash, vim …)
I did the hard work by compilation.

Downloading of Sources :

pkg install wget-1.19.1
cd /usr/src
wget https://sourceforge.net/projects/playsms/files/playsms/Version%201.4/playsms-1.4.tar.gz

Untar :

tar -xvzf playsms-1.4.tar.gz

Building :

portsnap fetch update

cd /usr/ports/www/nginx
make config-recursive ; make install clean

cd /usr/ports/databases/mysql56-server
make config-recursive ; make install clean

cd /usr/ports/lang/php56
make config-recursive ; make install clean

cd /usr/ports/lang/php56-extensions
make config-recursive

Check php extensions : curl ; gb ; gettext ; imap ; mbstring ; mcrypt ; mysql ; mysqli ; openssl

make install clean

Edit of rc.conf :

vim /etc/rc.conf

Securing MySQL :

service mysql-server start
mysql_secure_installation

Nginx Configuration :

vim /usr/local/etc/nginx/nginx.conf

Nginx Test :

nginx -t

Php-fpm configuration :

vim /usr/local/etc/php-fpm.conf

cp /usr/local/etc/php.ini-production /usr/local/etc/php.ini
vim /usr/local/etc/php.ini

PHP Test :

vim /usr/local/www/nginx/info.php

Restrat services :

service nginx restart
service php-fpm restart

Essai d’accès à : http://[@IP_du_serveur]/info.php

Configure install playsms :

cd /usr/src/playsms-1.4
cp install.conf.dist install.conf
vim /usr/src/playsms-1.4/install.conf

Script Adaptations for FreeBSD :

vim /usr/src/playsms-1.4/install-playsms.sh

Add two quote for sed command :

Change "." for ":"

Remove "r" line 260

vim /usr/src/playsms-1.4/daemon/linux/bin/playsmsd.php

Line 1 change path with "local"

vim /usr/src/playsms-1.4/daemon/linux/bin/playsmsd.php

Remove "e" for ps command

Bash install :

pkg install bash-4.4.12_2

Playsms install :

bash install-playsms.sh

chown -R www:www /usr/local/www/nginx/playsms
chmod -R 700 /usr/local/www/nginx/playsms

Source : https://www.digitalocean.com/community/tutorials/how-to-install-an-nginx-mysql-and-php-femp-stack-on-freebsd-10-1

Actualy, Playsms is working, bug I have never succeeded has to change the language.
The value changes in database, but does not apply in the php …

I create a Debian in VM with the same procedure.
The language change correctly in a Debian VM.
I have copy a configuration file of php, nginx, without success
I have compare a php module installed with php -m, without success
I have test if javascript was active with a testing page realised for Salman Akhlaqi ==> Javascript was active
(https://stackoverflow.com/questions/4454551/check-if-javascript-is-enabled-with-php/31088195)

Ideas?
Thank you in advance.

Geoffrey


(MOREL Geoffrey) #2

Halo Anton, maaf saya gangu anda tapi saya perlu tolong, nga ada orang yang bisah bantu saya. Apa anda pikir dari probem saya?


(MOREL Geoffrey) #3

Hi guys,

I progress in my “language fixed quest”.
When I activate a verbose mode, I have this result on freebsd

But not in Debian (identical VM)

Can you tell me if the language module use a locale variable ?

Thanks you in advance.