playSMS Forum

Auto Replay Message Footer

I’m using the Auto Reply feature. Is there a way to stop it from sending the User name as the Message footer at the end of the message?

I was able remove it from the Compose message function, but not the Auto Reply

SMS footer is in User preferences, and also check in Main configuration (kinda forgot)

anton

I had already changed the setting in User preferences, and it works for Compose a Message.

However, it ignores that setting for Auto Reply. Instead, it uses “@username” for the footer.

Is it possible to disable footer?

hmm I’ve tested this in my local install 1.4.3, mine didn’t send out reply with footer on autoreply

log also shown no footer

cat log/playsms.log | grep sms_footer
cat log/playsms.log | grep "sendsms # final"

anton

- - 2020-06-29 20:48:50 PID5efa53b2acde9 - L3 sendsms_intercept # outgoing modified sms_sender:[+1xxxyyyzzzz] sms_footer:[@rockya1] sms_to:[+1xxxyyyzzzz] sms_msg:[https://www.example.com/xxxxxx-detailxxxxxxxxxxxxxx] uid:[2] gpid:[0] sms_type:[text] unicode:[0] queue_code:[fe9ddb44d3dbc3d3e16bb1de928aab99] smsc:[fathom]

- - 2020-07-03 17:31:38 PID5eff6b7a140ab - L3 sendsms # final smslog_id:61 gw:telnyx smsc:fathom message:Want to take a virtual tour? Tap here:  https://www.example.com/demo/xxxxxx @rockya1 len:97

User rockya1 must remove default footer from their user configuration:

I can see if I removed the footer I will have empty sms footer on log, and I can see it when I add footer on user configuration:

anton

After a restart, that fixed it! Thank you!

didn’t expect that to be the answer, it should not need a daemon restart

but, maybe its a bug. can you help confirm this ?

Without restarting the daemon:

  1. Add the footer, test the autoreply
  2. Change the footer, test autoreply
  3. Remove/empty the footer, test autoreply

And re-done the test above with restarting the daemon each time

Only if you’re available :slight_smile: Thanks.

anton

I have verified that any change made to that field will only take affect after a re-start.

ok, I know the culprit and it will be fixed, it was due to sendsmsd using data of logged in user gathered during init, so its not updated without restart

quick workaround is by adding TRUE to nofooter option in sms_autoreply:

edit plugin/feature/sms_autoreply/fn.php line 98

change this line:

list($ok, $to, $smslog_id, $queue) = sendsms_helper($c_username, $sms_sender, $autoreply_scenario_result, 'text', $unicode, $smsc);

to this line (adding TRUE at the end):

list($ok, $to, $smslog_id, $queue) = sendsms_helper($c_username, $sms_sender, $autoreply_scenario_result, 'text', $unicode, $smsc, TRUE);

and then restart playsmsd, once

anton

So this fix will block any footer, correct?

Also, can playsms notify by email or sms when a caller uses the autoreply feature? For example, someone texts my autoreply number and I get a notification to my email or cell that they did?

Yes

Autoreply dont have this feature. Quick fix you have to add it manually, right after sendsms command (same fn.php)

Ill give you example later.

Anton

This is example of sending email:

This is example of saving it to user’s inbox (and then they can forward it to email through menu):

anton